Album artist information in artist browser

You can post all your bug reports here. Make sure to include a maximum of information to help ease the investigation.

Album artist information in artist browser

Postby smiffy » Sun Jan 08, 2012 10:09 pm

I have a confusing problem where I have selected to display information from album artists in the artist browser. I want this as I have a number of albums with the album artist of 'various artists' - and of course there are track artists within these albums. The artist browser is randomly showing an assortment of track artists though. There seems to be no method to who it shows, it just puts in an odd selection of track artists and then it links to the 1 song that they have done on a 'various artists' album.

I have checked all my ID3 tags and there seems to be no problem with the information here in ID3v2 tags - all is shown accurately. So I'm lost as to why this might be. When editing the tracks concerned in PlayerPro the information is fine - but PlayerPro doesn't give me the option to see an album artist so I don't know if that info is there.

I have wiped and re-created the music on the Android phone to force the database to refresh and have triggered a refresh of the media store to no avail.

Has anyone seen this or can anyone help?
smiffy
 
Posts: 5
Joined: Sun Jan 08, 2012 9:53 pm

Re: Album artist information in artist browser

Postby jmccraney » Tue Jan 10, 2012 9:48 am

Yep, I've got the same problem. Certain tracks (but not all) are listed under their track artist rather than album artist. I have this problem with both mp3 and wma files on either the internal or external SD cards. I have re-synced it several times with different software and it still recurs, the latest sync with Cheetah Sync. For tracks where the track artist and album artist are the same, the browser works just fine, but when the track artist is different, the tracks are not included in the album. It appears that if the last track does not match the album artist, then the track artist is given its own album artist category. In addition, the artist "Various Artists" does not appear at all, but the track(s) by the final track artist still appear. I also notice that when browsing albums with the list layout, it displays the album artist as the track artist of the last track, so I assume this may be related. Hope this info helps and we can get this bug fixed!
jmccraney
 
Posts: 9
Joined: Sat Dec 31, 2011 5:08 am

Re: Album artist information in artist browser

Postby smiffy » Wed Jan 11, 2012 7:57 pm

Yup, you have it - that's exactly what I am seeing! So it's not just me then - this does seem to be exactly the problem.

Here's a second to hoping that this gets noticed by the development team and is looked into. Any updates welcome.
smiffy
 
Posts: 5
Joined: Sun Jan 08, 2012 9:53 pm

Re: Album artist information in artist browser

Postby smiffy » Sat Feb 11, 2012 10:41 am

Any further news from developers on this? Have just got the latest version of PlayerPro v2.3 and no sign of any fixes here. This has appeared in a number of other posts in the forum too so it's obviously a notable concern, but with very little response from developers. Is the developer going to take any notice?

Any updates welcome, particularly if I have missed something.
smiffy
 
Posts: 5
Joined: Sun Jan 08, 2012 9:53 pm

Re: Album artist information in artist browser

Postby jmccraney » Wed Feb 29, 2012 1:34 am

Yeah, I'm still experiencing the problem as well. The developer did add an option to change the Album Artist in the tag editor, but although it is a welcome addition, it does not fix the problem as the tag editor reads the album artist correctly (ie. not as it appears in the artist library).
jmccraney
 
Posts: 9
Joined: Sat Dec 31, 2011 5:08 am

Re: Album artist information in artist browser

Postby toonboy616 » Thu Apr 12, 2012 1:21 am

I have just downloaded the trial tonight and low and behold i have found this very annoying problem also. On top of this when i updated some tags on my pc and deleted and recopied the mp3s to the phone the library is not updated to reflect the changes to the id3tags.... how do you force a complete update of the library???? the button in the setting for the music store update does NOTHING!!!

If this is recognised by the developers i will still buy the full version.

running One X on ICS4
toonboy616
 
Posts: 4
Joined: Thu Apr 12, 2012 1:18 am

Re: Album artist information in artist browser

Postby toonboy616 » Tue Apr 17, 2012 4:52 pm

any news on these updates?
toonboy616
 
Posts: 4
Joined: Thu Apr 12, 2012 1:18 am

Re: Album artist information in artist browser

Postby RonMoses » Tue Jul 10, 2012 6:26 pm

Adding my voice to the choir. As an example, I have a number of mp3s with Artist tags of Dave Brubeck and The Dave Brubeck Quartet. Even though the Album Artist tags are all clearly set to Dave Brubeck on my PC, PlayerPro shows them as blank and will not update them. I've tried this in folder view, artist view, and even album view. I even tried setting the Album Artist tags blank, and then setting them to Dave Brubeck, with no effect.

Edits to the Album Artist tag simply do not stick as far as I can tell. This is a big problem for me.

UPDATE: I installed iTag and it confirmed that the Album Artist tag information is correct. So it's a matter of PlayerPro (or whatever Android API it relies on) not reading it.

ron
RonMoses
 
Posts: 8
Joined: Tue Jul 10, 2012 6:08 pm

Re: Album artist information in artist browser

Postby ksutherland » Thu Jul 12, 2012 9:14 pm

I'm experiencing this problem too. Looks like a number of people have posted about this and no word from the developer yet acknowledging the issue or indicating that a fix will be coming soon. Really love PlayerPro except for this one annoyance.
ksutherland
 
Posts: 3
Joined: Thu Jul 12, 2012 9:05 pm

Re: Album artist information in artist browser

Postby stvaustin » Fri Jul 13, 2012 3:41 am

Mine is album art missing after reboot (sometimes). Had to reload PlayerPro's data from Titanium Backup after reboot.
stvaustin
 
Posts: 1
Joined: Fri Jul 13, 2012 3:35 am

Next

Return to Bug reports

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron